Silverblue Test Day

More information about the event can be found here: http://fedoraproject.org/wiki/Test_Day:2019-04-05_Silverblue_Testday
Go back to List of Events.

Results

Clicking on the testcase name will show you the appropriate "how to test" page.
Click on the Enter result button, to enter result.
Note: results are cached and realoaded from the database each 10 seconds.

Basic tests

Username Profile Boot Logging Services Start SELinux Service Manipulation Comments
Enter result Enter result Enter result Enter result Enter result
akarshanbiswas Desktop: gigabyte AMD 3+ ; CPU:amd fx 6400; AMD RADEON RX550
alciregi MacBookPro5,5
jakfrost QEMU Virt-Manager layered on Fedora Silverblue 30 Beta which is running on AMD Phenom 6 Core SMBIOS [1] [2] [3] [4] [5] 1. [Terminated] was the only message and it just wouldn't boot. First tried in Gnome Boxes and no go, so tried in Virt-Manager which normally works every time, fails with same message.
2. journalctl -b --system --user all worked as expected with copious log information
3. systemctl list-units shows mcelog loaded but failing to start or run. This also happens on my bare metal unit this VM is running on.
4. semodule -l had to be run as sudo, reported expected long listing.
5. I was able to use systemctl stop/start to stop then start the cups.service as a test.
kcalvelli Intel® Core™ i7-7700 CPU @ 3.60GHz × 8, AMD® Radeon (tm) rx 460 graphics
lachmanfrantisek Sony Vaio VPCM13M1E [1] 1. rsyslog not installed
lruzicka QEMU
lruzicka bare metal, AMD based computer
mmorrell2016 VirtBox VM, 1CPU, 8G RAM, 20G Storage [1] 1. Lots of excess logs for gnome-shell: failed to flip onscreen: drmModePageFlip Lots of excess logs for kernel: [drm] Error -12 pinning new fb, out of me?
nielsenb Compaq 8510w Intel Core 2 Duo T9300 AMD RV630 [1] 1. Created user is not in the sudoers file, rsyslog not installed by default
pnemade kvm x86_64 [1] [2] [3] [4] [5] 1. Successfully installed and boot the Graphical OS
2. journalctl logging is enabled, also saw some gnome-software failure log related to failed to get updates
3. All services started normally with no failure. journalctl showed few red lines but the log contained nothing about breaking the order cycle.
4. Enforcing mode
5. working fine to enable/disable ssh service after reboot
renault GNOME Boxes, Silverblue x86_64
sayanchowdhury qemu, X86_64
shaan7 Baremetal on spinning disk, Intel Core i7 4770K, Asus Z87-Pro, NVIDIA GTX 970 [1] 1. Clicking on a video in "Getting Started" freezes the system (cant move mouse, keys don't work, cant even toggle num/caps lock). I can hear the audio.
sinnykumari qemu, X86_64
stkl QEMU (F29 x86_64 host), Intel CPU [1] 1. rsyslog not installed
yisooan QEMU [1] 1. rsyslog wasn't installed so case 3 wasn't tested.

Workstation

Username Profile install flatpak gnome update notif gnome software addons rpm-ostree upgrade and rebase rpm-ostree rebase IDE Test Chrome Fedora Toolbox Comments
Enter result Enter result Enter result Enter result Enter result Enter result Enter result Enter result
jakfrost QEMU Virt-Manager layered on Fedora Silverblue 30 Beta which is running on AMD Phenom 6 Core SMBIOS [1] [2] [3] [4] [5] [6] [7] 1. Gnome Software wouldn't show any software availability even after restart of the VM. Verifying the Flathub remote was added correctly via Gnome Software and the Flathub easy setup option showed it set as flathub and by system. Attempted to install Gedit at the command line with flatpak worked and I was able to run it from the command line but not via the desktop icon. Setup the Flathub remote as again with the --user option and logged out and back in but Gnome SW still didn't show any available software to install, though some extensions became visible. The Gnome Software application is extremely slow in response, and this could be due more to the VM since my f30SB beta is fine on bare metal.
2. Tried to force an update via Gnome SW by checking for one. It error'd with the message `Error calling StartServiceByName for org.freedesktop.PackageKit: Timeout was reached`
3. Like the flatpaks, I couldn't get extensions to work or even show up in Gnome Software.
4. I was able to rebase and rollback but it still didn't solve my issues.
5. Could create and compile a simple C project in builder after installing it as a flatpak.
6. Didn't download it, don't use it
7. Used it right at first boot up to get the link for installing the Flathub remote.
kcalvelli Intel® Core™ i7-7700 CPU @ 3.60GHz × 8, AMD® Radeon (tm) rx 460 graphics [1] [2] [3] [4] 1. Gnome Software reports "No Additional Repositories" after adding the repository
2. No update notifications in Gnome Software
3. Categories are listed in Software, but instead of applications showing up there are three dots (...) within each square. Clicking on a square does nothing. Logs show recurring error: Error calling StartServiceByName for org.freedesktop.PackageKit
4. Unable to test through Software.
lachmanfrantisek Sony Vaio VPCM13M1E [1] [2] [3] [4] 1. After `rpm-ostree upgrade` and reboot, everything works well.
2. Firefox opened the repo-file as a plain text. (Terminal installation went without problems.) Gnome software did not show the new repository, restarting gnome-software did not help. (`flatpak remotes` showed `gnome-apps-nightly`) Updates tab showed an error (Error calling StartServiceByName for org.freedesktop.PackageKit: Timeout was reached) The same error was shown in the debug output. (failed to resolve third party repo, failed to load metadata, failed to set proxies, failed to get featured apps, failed to refresh the cache)
3. no updates notification (pkom shows the same error as gnome-software in [1]: Error calling StartServiceByName for org.freedesktop.PackageKit: Timeout was reached)
4. 1. cannot search due to the missing repository in gnome-software, getting info and launching works for the installed apps 2. I've tried to remove gnome-discs but that app cannot be removed (removing not available) 3. Listing all apps does not work. (Same problem as in [1] and [2].) Listing installed apps works well. 4. Other categories/picks shows nothing. 5. not tested 6. not tested
lruzicka QEMU [1] [2] [3] [4] 1. #1696193, Seems the fix is on the way.
2. Gnome software is useless on Silverblue, because it does not show any application to install.
3. So, even if it through an exception about the time out, leaving it wait for a couple more minutes resulted in Sublime installed, so this is a little bit weird. I still think that the test is NO PASS though.
4. The transaction ends with a time out. Nothing can be installed using Software, except for the Flathub configfuration file. Using CLI works normally.
lruzicka bare metal, AMD based computer
mmorrell2016 VirtBox VM, 1CPU, 8G RAM, 20G Storage [1] [2] [3] [4] 1. Firefox just download text file for repo config. Installed repo by command line but GS does not show any new repos added. All the software items show "..." in a box with no image. Clicking on one has no result. I can view the installed applications. Updates shows an error message "Error calling StartServiceByName for org.freedesktop.Packagekit: Timeout was reached"
2. All the software items show "..." in a box with no image. Clicking on one has no result. I can view the installed applications. Updates shows an error message "Error calling StartServiceByName for org.freedesktop.Packagekit: Timeout was reached"
3. No updates available
4. Cannot install any software by Gnome Software
nielsenb Compaq 8510w Intel Core 2 Duo T9300 AMD RV630 [1] [2] [3] [4] 1. Firefox shows the repo file as text, it does not open for install. After installing using CLI, gnome-software reports "No Additional Repositories".
2. Update notification never appeared, even after shortening waiting time and rebooting.
3. No software is shown.
4. gnome-software displays notification saying "you do not have permission to install software", does not ask for elevated privileges.
pnemade kvm x86_64 [1] [2] [3] [4] [5] [6] [7] [8] [9] 1. Well I should say this is FAILED actually as Firefox opened the repo file as just plain text file, but install with CLI went errorfree. Then tried to check if repo is available in gnome-software but it keep showing spinning icon and could not show available repo list.
2. pkmon did show the timeout was reached error also
3. I don't think this test case work for those who pick 20190403 iso as there is no further updates pushed, hence gnome-software will not find any update, thus no notification by gnome-software.
4. gnome-software unable to get metadata to show list of packages their icons due to "timeout was reached" error.
5. Able to upgrade and rebase to F30 successfully.
6. Worked fine on one on my old F29 SB VM, simple rebase worked successfully.
7. After applying gnome-software-3.32.0-5.fc30.x86_64.rpm update, IDE install worked fine.
8. pkmon gave "Failed to get properties: Error calling StartServiceByName for org.freedesktop.PackageKit: Timeout was reached" error so unable to install any application
9. I can install google-chrome-stable successfully.
sinnykumari qemu, X86_64 [1] [2] 1. opening gnome-apps-nightly doesn't work. Works adding gnome-apps-nightly repo through command line
2. Needs latest gnome-software due to bug https://bugzilla.redhat.com/show_bug.cgi?id=1696193 but not yet available in Silverblue ostree . Installed through command line "sudo rpm-ostree override replace https://kojipkgs.fedoraproject.org//packages/gnome-software/3.32.0/5.fc30/x86_64/gnome-software-3.32.0-5.fc30.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/gnome-software/3.32.0/5.fc30/x86_64/gnome-software-rpm-ostree-3.32.0-5.fc30.x86_64.rpm " and rebooting , works fine
stkl QEMU (F29 x86_64 host), Intel CPU [1] [2] [3] 1. Firefox did not open the repo file, but gave plain text output. CLI went errorfree. Repo check in gnome-software keeps spinning and does not show the repo list.
2. Update notification does not show up. Waited for about 90min, reset check timestamp and waited another 20min.
3. Gnome Softwre just shows 3 dots on each icon and no app to install.
yisooan QEMU [1] [2] [3] [4] [5] [6] [7] [8] [9] [10] 1. Not able to open it in firefox. But verified that 'gnome-apps-nightly' shows up in the list.
2. Skip case 5. Case 6: When an application installed without reboot, the rpm source doesn't show up correctly.
3. It has a bug. ksinny talked about the issue in irc and therefore it still needs patches.
4. It worked to rebase back and forth 29 and 30
5. It worked well although back to 29.
6. It needs to add flathub repo first. "flatpak remote-add flathub https://flathub.org/repo/flathub.flatpakrepo", this lets you allow to download flatpak apps in gnome-software. However, when I followed the step for sublime text, gnome-software showed a message up that "Failed to install file: not supported"
7. Not able to test since software has a bug as the same reason as "gnome software addons"
8. After failed to install it in the first try, reboot, tried to install it again and therefore succeeded.
9. Stuck in 95% and no response from rpm-ostree, not even able to cancel the transaction with Ctrl+C. Nothing can do with rpm-ostree, even in another terminal window.
10. I could use dnf command inside a container.
Wiki Metadata